Vista Media Center – (some of the) Live TV problems solved!

Windows Vista

Some of the problems I had with my Windows Vista Media Center are solved!! The reason this message is in English is because I want to share this info not only with the Dutch 🙂

If you have the problems described in the following messages you should install the updates mentioned below :

First I tried to install Windows Vista SP1, but that won’t work on my Dutch Vista Ultimate. Just a few hours after the post about the problem about installing SP1 (and using Live TV on Media Center) a former collegue told me some new Vista updates came out. I downloaded the updates and YESssssss Live TV is working right now. The only problem I still have is that I can’t record and watch TV (through the second tuner). Let’s hope this will also be fixed in a furure update.

So if you have any problems using Live TV on your Windows Vista x64 system, try to install the updates mentioned below (reboot) and I’m almost sure that, if you have the same problems as me, Live TV is working again…

Vista:
KB941229 (x86) (x64)     : This update addresses issues with Media Center for Microsoft Vista.
KB941651 (x86) (x64)     : This is a reliability update. Install this update to improve the reliability of Windows Media Player 11 for Windows Vista in certain scenarios.
KB941600 (x86) (x64)     : This update resolves some reliability issues in the USB core components on the Windows Vista operating system.
KB941649 (x86) (x64) Deze download is alleen beschikbaar voor gebruikers met legale Winodws producten. Klik op het icon voor meer informatie. : This update resolves some compatibility and reliability issues in Windows Vista. By applying this update, you can achieve better reliability and hardware compatibility in various scenarios.

I also posted the updates in my former post, but that post was mostly in Dutch so I post them again for my English friends.

UPDATE : Right now I do have one more problem : Only one tuner is working, so you still can’t watch one channel and record another, but it ‘s a start. Please let me know if you have both tuners working correctly so I can publish the how-to on my blog!